Project

General

Profile

Bug #703

Timeline Color Selection from Non-Default State Not Working

Added by Ronak Buch over 4 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
11/13/2015
Due date:
% Done:

50%

Estimated time:
1.00 h

Description

For the timeline view, when a non-default color scheme (e.g. color by frequency) is chosen, doing manual color selection does not change the color of entry points on the timeline.

History

#1 Updated by Ronak Buch over 3 years ago

  • Assignee changed from Ronak Buch to Keshav Santhanam

#2 Updated by Keshav Santhanam over 3 years ago

  • Start date changed from 03/19/2015 to 11/13/2015
  • % Done changed from 0 to 50
  • Status changed from New to In Progress
  • Estimated time set to 1.00 h

When user clicks "Change Entry Point Color", MainWindow.runObject[data.myRun].setEntryColor is called from the actionListener and updates entryColor[entryIndex] correctly. However, the repainting process is then kicked off and the determineColor method in EntryMethodObject ends up resetting entryColor[entryIndex]. The colors remain updated if the final else block simply returns the existing value of MainWindow.runObject[data.myRun].entryColors[entryIndex] instead of colToSave. However, this might not be the desired behavior as the colToSave variable is completely ignored.

#3 Updated by Ronak Buch about 2 years ago

  • Assignee changed from Keshav Santhanam to Ronak Buch

#4 Updated by Ronak Buch 9 months ago

  • Status changed from In Progress to Closed

Unable to reproduce on latest version of Projections.

Also available in: Atom PDF