Project

General

Profile

Bug #522

static linking breaks on multicore builds with 'undefined reference to `get_myaddress''

Added by Jim Phillips about 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Machine Layers
Target version:
Start date:
06/19/2014
Due date:
% Done:

100%

Spent time:

Description

On an NVIDIA ARM64 machine, --with-production works but -optimize gives link error:

../../../bin/charmc -language charm++ -o hello hello.o
../../../bin/../lib/libck.a(debug-charm.o): In function `hostInfo(void*, void*, CpdListItemsRequest*)':
debug-charm.C:(.text+0x40): undefined reference to `get_myaddress'
collect2: error: ld returned 1 exit status
Fatal Error by charmc in directory /home-2/jphillips/NAMD_CVS-2014-06-18_Source/charm-6.6.0-rc3/multicore-arm7/tests/charm++/simplearrayhello
Command g++ -D_REENTRANT -rdynamic -o hello -L../../../bin/../lib -I../../../bin/../include ../../../bin/../lib/libldb-rand.o hello.o moduleinit29126.o ../../../bin/../lib/libmemory-default.o ../../../bin/../lib/libthreads-default.o -lckmain -lck -lconv-cplus-y -lconv-core -lconv-util -lconv-partition -lpthread -lckqt -ldl -lm returned error code 1
charmc exiting...

History

#1 Updated by Eric Bohm almost 5 years ago

  • Assignee set to Ehsan Totoni

#2 Updated by Phil Miller almost 5 years ago

  • Target version changed from 6.6.1 to 6.7.0

#3 Updated by Eric Bohm over 4 years ago

  • Assignee changed from Ehsan Totoni to Eric Bohm

#4 Updated by Eric Bohm over 4 years ago

  • Status changed from New to In Progress

RSA ID for TCBG has expired. Will get a new one so I can reproduce the bug.

#5 Updated by Eric Bohm over 4 years ago

  • Status changed from In Progress to Rejected
  • % Done changed from 0 to 100

I cannot reproduce this bug on cupertino. I suspect the actual issue was resolved by other changes in the interim.

I have found numerous compilation bugs arise with high levels of parallelization on the make (-j or -j8). Those seem to be compiler crashes in gcc, probably due to memory constraints. I'd consider those upstream bugs rather than charm bugs. I'm reluctant to try to enforce low levels of parallel compilation as the environmental toolchain issues may be resolved in subsequent releases.

Building with -j2 has been safe so far.

#6 Updated by Phil Miller over 3 years ago

  • Target version deleted (6.7.0)

#7 Updated by Sam White over 2 years ago

  • Status changed from Rejected to New
  • Subject changed from multicore-arm7 --no-build-shared -optimize undefined reference to `get_myaddress' to static linking breaks on multicore builds with 'undefined reference to `get_myaddress''

This same error happens when building examples/ampi/Cjacobi3D with -tlsglobals on multicore-linux64 and is reproducible there (see autobuild). The common denominators are that these are multicore builds using static rather than dynamic linking ('-tlsglobals' implicitly passes '-static' to the linker).

#8 Updated by Sam White over 2 years ago

  • Target version set to 6.8.1
  • Assignee deleted (Eric Bohm)

#9 Updated by Phil Miller over 2 years ago

It would seem that the thing to do about this would be to statically link everything with the exception of libc. This may take some careful trickery in how we do the linking setup, but would also resolve some other warnings we've seen.

#10 Updated by Eric Bohm about 2 years ago

  • Assignee set to Seonmyeong Bak

#11 Updated by Eric Bohm almost 2 years ago

  • Target version changed from 6.8.1 to 6.9.0

#12 Updated by Seonmyeong Bak over 1 year ago

  • Target version changed from 6.9.0 to 6.9.1

#13 Updated by Sam White over 1 year ago

  • Assignee deleted (Seonmyeong Bak)

#14 Updated by Eric Bohm over 1 year ago

  • Assignee set to Evan Ramos

#15 Updated by Evan Ramos over 1 year ago

  • Status changed from New to In Progress

I am unable to reproduce this. My command was:

./build AMPI multicore-linux-x86_64 -j4 --no-build-shared -optimize && pushd multicore-linux-x86_64/examples/ampi/Cjacobi3D && make test TESTOPTS="++local"

#16 Updated by Evan Ramos over 1 year ago

  • Status changed from In Progress to Feedback

Proposing closure unless the issue can be reproduced.

#17 Updated by Evan Ramos about 1 year ago

  • Status changed from Feedback to Closed

Closing because the issue has not been reproduced.

#18 Updated by Evan Ramos 11 months ago

  • Target version changed from 6.9.1 to 6.9.0

Also available in: Atom PDF