Project

General

Profile

Bug #435

timeline does not show correctly about idle overhead

Added by Yanhua Sun over 5 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
03/12/2014
Due date:
% Done:

0%


Description

I do not know whether others have this problem. I found that after we added SDAG_RTS entry
in Charm, the time profile , usage profile in Projections can not display correctly.

In timeline, the SDAG_RTS seems not much time. However, when using time profile, it is totally messed up. All overhead time goes away. Instead, it is all SDAG_RTS time. This is wrong.

The projections data can be found here

/dcsdata/home/jessie/PPL/git/benchmarks/leanmd/prj_root

History

#1 Updated by Yanhua Sun over 5 years ago

Ronak, any progress on this?

#2 Updated by Ronak Buch over 4 years ago

  • Status changed from New to In Progress

#3 Updated by Ronak Buch over 4 years ago

  • Status changed from In Progress to Feedback

While the logs at /dcsdata/home/jessie/PPL/git/benchmarks/leanmd/prj_root do indeed display erroneous behavior, it is suspicion that the logs themselves are at fault. I went through and manually calculated the values directly, and they seem to be correct. I was unable to reproduce the issue with new logs. Unless somebody can provide logs from a "modern" build of Charm, this should be rejected.

#4 Updated by Sam White over 1 year ago

  • Status changed from Feedback to Rejected

Also available in: Atom PDF