Project

General

Profile

Bug #2052

Build script does not support thread sanitizer

Added by Venkatasubrahmanian Narayanan 3 months ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Category:
-
Target version:
-
Start date:
02/04/2019
Due date:
% Done:

100%


Description

The build script does not support building Charm++ with the GCC thread sanitizer.

History

#1 Updated by Sam White 3 months ago

Can you update the issue with the failed output?

In general when reporting an issue you should provide how exactly to reproduce the issue (your full charm build command, what type of build/environment if applicable, how to run the test case if applicable) as well as the output from whatever failed.

#2 Updated by Evan Ramos 2 months ago

I was able to run with TSan successfully using these lines:

./build all-test multicore-linux-x86_64 tsan -j12 -g3 -fsanitize=thread && cd multicore-linux-x86_64-tsan/tests/charm++/simplearrayhello && TSAN_OPTIONS="log_path=log.txt" ./hello +p2
./build all-test netlrts-linux-x86_64-smp tsan -j12 -g3 -fsanitize=thread && cd netlrts-linux-x86_64-smp-tsan/tests/charm++/simplearrayhello && TSAN_OPTIONS="log_path=log.txt" ./hello +p2

(The redundant -fsanitize=thread is so that the tests and examples see the flag and not just the RTS.)

#3 Updated by Venkatasubrahmanian Narayanan about 1 month ago

  • % Done changed from 0 to 100
  • Status changed from New to Rejected

It turns out that the problem is with the GCC version used to build Charm++ - GCC 4.x does not properly support the thread sanitizer.

Also available in: Atom PDF