Project

General

Profile

Bug #1944

OpenMP library doesn't build when 5.0 is available

Added by Joseph Hutter 2 months ago. Updated 2 months ago.

Status:
Merged
Priority:
Low
Category:
OpenMP integration
Target version:
Start date:
07/10/2018
Due date:
% Done:

0%

Tags:

Description

When building OpenMP libary, if you have 5.0 available, you see this during configure:
-- LIBOMP: OpenMP Version -- 50
And then you get this later on:
CMake Error: File /projects/cwi/buildcfs/charm/verbs-linux-x86_64-omp-smp/tmp/libs/conv-libs/openmp_llvm/runtime/src/include/50/omp.h.var does not exist.
So it fails! Fortunately, it's not difficult to work around, but it would be nice if there were support in runtime/src/include for 50. Current workaround:
cd tmp/libs/conv-libs/openmp_llvm/runtime/src/include; cp -r 45 50; make -C ../../..;

History

#1 Updated by Seonmyeong Bak 2 months ago

  • Status changed from New to Implemented

#2 Updated by Sam White 2 months ago

  • Target version set to 6.9.0
  • Status changed from Implemented to Merged

Also available in: Atom PDF