Project

General

Profile

Bug #1859

Megampi hangs on multicore-linux-x86_64 with +CmiSleepOnIdle

Added by Nitin Bhat 3 months ago. Updated 17 days ago.

Status:
New
Priority:
Low
Assignee:
Category:
AMPI
Target version:
-
Start date:
04/13/2018
Due date:
% Done:

0%


Description

Test case causing hang:


../../../bin/testrun  ./pgm +p2 +vp4  +CmiSleepOnIdle
Running command: ./pgm +p2 +vp4 +CmiSleepOnIdle

Autobuild: http://charm.cs.illinois.edu/autobuild/old.2018_04_13__01_01/multicore-linux-x86_64.txt

History

#1 Updated by Sam White 3 months ago

  • Target version set to 6.9.0
  • Category set to AMPI

#2 Updated by Sam White 3 months ago

This hang only happens when the test is run on charity with "+CmiSleepOnIdle". It doesn't reproduce on other lab machines. It also doesn't reproduce on charity under gdb. For now I think we just remove +CmiSleepOnIdle from the autobuild TESTOPTS, take this issue of 6.9.0, and revisit it later.

#3 Updated by Sam White 3 months ago

  • Target version deleted (6.9.0)
  • Priority changed from High to Normal

#4 Updated by Sam White 3 months ago

  • Subject changed from Megampi hangs on multicore-linux-x86_64 to Megampi hangs on multicore-linux-x86_64 with +CmiSleepOnIdle

#5 Updated by Sam White 3 months ago

multicore-linux-x86_64 autobuild is now hanging in tests/ampi/privatization: https://charm.cs.illinois.edu/redmine/issues/1858

#6 Updated by Sam White 17 days ago

  • Priority changed from Normal to Low

Also available in: Atom PDF