Project

General

Profile

Bug #1785

The manual isn't building correctly / updating online

Added by Sam White over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
High
Assignee:
PPL
Category:
Documentation
Target version:
Start date:
01/30/2018
Due date:
% Done:

0%


Description

The Charm++ manual and other manuals are not building correctly since 10 days ago according to Jenkins. This means that the online versions are not automatically updating.

http://localhost:8080/job/charm-documentation/

History

#1 Updated by Matthias Diener over 1 year ago

  • Assignee changed from Matthias Diener to PPL

The build error is:

make[1]: Leaving directory '/scratch/jenkins/workspace/charm-documentation/doc/charj'
rm -rf /www/manuals/backup
mkdir -p /www/manuals/backup && \
mv /www/manuals/pdf /www/manuals/html /www/manuals/backup
mkdir: cannot create directory ‘/www’: File exists
Makefile:29: recipe for target 'web' failed
make: *** [web] Error 1
Build step 'Execute shell' marked build as failure
Finished: FAILURE

On January 19th (=10 days ago), the filesystem on the build machine (panache) was somehow changed so that /www is now a symlink to /web/www, which results in the mkdir failure shown above:

mdiener@panache $ ls -l /www
lrwxrwxrwx 1 root root 8 Jan 19 16:21 /www -> /web/www
mdiener@panache $ mkdir -p /www
mkdir: cannot create directory ‘/www’: File exists

#3 Updated by Matthias Diener over 1 year ago

The issue has been fixed on panache. The above patch was not necessary.

#4 Updated by Matthias Diener over 1 year ago

  • Status changed from New to Resolved

#5 Updated by Ronak Buch over 1 year ago

This was caused by /web on panache not being mounted properly for some reason. Running sudo mount /web fixed it.

#6 Updated by Sam White over 1 year ago

  • Status changed from Resolved to Closed

Marking 'Closed' so redmine will remove it from the 'Open' category

Also available in: Atom PDF