Project

General

Profile

Bug #1724

Make BGQ builds default to using bgclang

Added by Sam White 23 days ago. Updated 16 days ago.

Status:
Implemented
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
10/27/2017
Due date:
% Done:

0%


Description

bgxlc and bggcc don't support C++11, so make the default compiler on BGQ builds bgclang.

History

#1 Updated by Sam White 23 days ago

If we detect that we are on a BGQ and can't find bgclang, fail and tell the user to do 'soft add +mpiwrapper-bgclang'.

Also, remove the BGQ xlc and gcc targets from autobuild since they will no longer be supported.

#2 Updated by Sam White 17 days ago

  • Assignee set to Sam White

#3 Updated by Sam White 16 days ago

  • Status changed from New to Implemented

Made bgclang the default compiler for all BGQ builds {pami/pamilrts/mpi}-bluegeneq: https://charm.cs.illinois.edu/gerrit/#/c/3230/

Also available in: Atom PDF