Project

General

Profile

Bug #1717

Sending variable sized messages with std::vectors

Added by Karthik Senthil over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/20/2017
Due date:
% Done:

0%


Description

This bug is based on the email sent by Joszef Bakosi to the mailing list : https://lists.cs.illinois.edu/lists/arc/charm/2017-10/msg00002.html

I was able to replicate the bug for a small test program attached with this bug report.

hello.C View (1.46 KB) Karthik Senthil, 10/20/2017 06:09 PM

hello.ci (321 Bytes) Karthik Senthil, 10/20/2017 06:09 PM

History

#1 Updated by Sam White over 1 year ago

  • Status changed from New to Rejected

The issue is with the message object's constructor not copying all the elements of the vector into its array members. I replied to the mailing list.

#2 Updated by Sam White over 1 year ago

  • Status changed from Rejected to Closed

Also available in: Atom PDF