Project

General

Profile

Feature #1351

For broadcasts, avoid copies for destination PEs on same node for [nokeep] messages

Added by Vipul Harsh over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
SMP
Target version:
Start date:
01/08/2017
Due date:
% Done:

0%


Description

For broadcasts with [nokeep] messages, RTS makes a copy for each PE on the same node. Copies can be avoided, if the message is read only.

History

#1 Updated by Sam White over 2 years ago

  • Assignee set to Vipul Harsh

#2 Updated by Sam White over 2 years ago

  • Target version set to 6.8.0

If you do "grep -r "CMK_BROADCAST_USE" charm/src/* you will see that currently this support is turned off by this macro, because CmiReference() and CmiFree() have no support for thread safety. The first (and possibly only) step to fixing this issue is to make their ref count atomic.
It would be good to have at least that much done by 6.8.0.

#3 Updated by Jim Phillips over 2 years ago

First, all features should have a target version of 6.8.0-beta1 or 6.8.1, not 6.8.0.
Second, even in smp mode it should be possible for all receivers on the same pe to share a message, even if each pe on the node has its own copy.
Finally, making the reference count atomic is not the same as a proper fence on message deletion. Rather than altering the behavior of existing generic utility functions you should write new ones that do what you actually want without imposing overhead on existing uses.

#4 Updated by Sam White over 2 years ago

  • Category set to SMP

#5 Updated by Vipul Harsh over 2 years ago

Seems like all destinations on the same PE do get one copy of the message for a broadcast

#6 Updated by Vipul Harsh over 2 years ago

  • Subject changed from For broadcasts, avoid copies for destinations on same node for [nokeep] messages to For broadcasts, avoid copies for destination PEs on same node for [nokeep] messages

#7 Updated by Vipul Harsh over 2 years ago

  • Description updated (diff)

#8 Updated by Vipul Harsh over 2 years ago

  • Status changed from New to Closed

Unable to reproduce different messages. Seems like for nokeep messages, the RTS does send the same message to each recipient on the same PE. Closing issue.

Also available in: Atom PDF