Project

General

Profile

Bug #1162

tracing runs segfault while writing logs

Added by Jim Phillips almost 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Tracing
Target version:
-
Start date:
08/14/2016
Due date:
% Done:

0%

History

#1 Updated by Jim Phillips almost 3 years ago

I'm consistently seeing segfaults or, most informatively, free(): invalid pointer, at the end of smp tracing runs on thousands of pes. This is for 6.7.1 and current head.

#2 Updated by Eric Bohm almost 3 years ago

  • Assignee set to Ronak Buch

#3 Updated by Sam White over 2 years ago

  • Target version set to 6.8.1
  • Category set to Tracing

#4 Updated by Phil Miller over 2 years ago

Has there been any investigation or follow-up on this? This could be pretty crippling for large-scale performance work.

#5 Updated by Ronak Buch over 2 years ago

I thought I had added a log here before, but I guess not. I had tried to replicate this when the bug was originally assigned and didn't have any luck in reproduction. I'll give it a go again to see if I can get an example case.

#6 Updated by Sam White almost 2 years ago

Still an issue?

#7 Updated by Sam White almost 2 years ago

Bump. Need to reproduce the failures and address them, or retarget to 6.9.0

#8 Updated by Ronak Buch almost 2 years ago

  • Status changed from New to Feedback

I was never able to reproduce this. Has this been an issue for you at all as of late, Jim (or anyone else)?

#9 Updated by Phil Miller almost 2 years ago

  • Status changed from Feedback to Closed
  • Target version deleted (6.8.1)

No longer seems to be reproducible. Re-open or open a new issue if it is observed again or can be reproduced.

Also available in: Atom PDF