Project

General

Profile

Bug #1001

netlrts with replicas leaves zombie processes behind

Added by Jim Phillips over 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Machine Layers
Target version:
-
Start date:
03/02/2016
Due date:
% Done:

0%

Estimated time:
4.00 h

Description

For netlrts-linux-x86_64-iccstatic/tests/charm++/megatest
./charmrun ++local +p16 ./pgm +replicas 4
will typically leave two zombie processes behind per invocation.
Without +replicas it works fine.

History

#1 Updated by Eric Bohm over 3 years ago

  • Assignee set to Bilge Acun

#2 Updated by Eric Bohm over 3 years ago

  • Estimated time set to 4.00 h

#3 Updated by Bilge Acun over 2 years ago

I am unable to reproduce this bug. After megatest run ends with the command above, I do; killall -9 pgm and I get pgm: no process found.

#4 Updated by Jim Phillips over 2 years ago

I can confirm it works for me too. OK to close.

#5 Updated by Bilge Acun over 2 years ago

  • Status changed from New to Resolved

#6 Updated by Phil Miller over 2 years ago

For the sake of diligence, it would be useful to know what commit actually resolved this. There have been about 650 commits since 6.7.0, which was released a few months before this was opened. So, bisection shouldn't take more than 10 commits tested. With each build and test being maybe 3 minutes, and time for scripting and such, that should be doable in under an hour.

#7 Updated by Bilge Acun over 2 years ago

Cannot reproduce the problem even with 6.7.0.

#8 Updated by Phil Miller about 2 years ago

  • Status changed from Resolved to Closed

Clearing out bugs like this.

Also available in: Atom PDF